Walking Patterns and Hip Contact Forces in Patients with Hip Dysplasia

Author: Ole Skalshøi
Supervisor: Henrik Sørensen

August 31, 2014
Preface

In this thesis gait patterns of patients with hip dysplasia are compared to a matching control group. The data, which had been collected for another study, was analysed using the movement simulation software, OpenSim. The report is divided in two parts: An article manuscript on gait patterns in hip dysplasia and a step-by-step tutorial for analysing experimental (MOCAP) data (determining joint angles, torques, muscle and joint contact forces).

The tutorial is meant as a supplement to the OpenSim documentation, to ease possible future implementation of the software at the Institute of Sport Science at Aarhus University. Such a supplement was considered necessary because the learning curve for OpenSim is rather steep until the basic analysis pipeline is understood. The documentation and tutorials provided by the OpenSim team are a great help, but do not cover making of settings files, model strength scaling and other simple, but important steps needed to make proper analyses.

The manuscript will provide documentation of the study itself and is intended to be published in its current form, although small changes might be done to meet the requirements from the publisher. Because the report is divided in two parts, that are meant to be read individually, page numbers and references are also handled separately.
Walking Patterns and Hip Contact Forces in Patients with Hip Dysplasia

Ole Skalshøi, Christian Hauskov Iversen, Dennis Nielsen, Julie Jacobsen, Kjeld Søballe, Inger Mechlenburg & Henrik Sørensen

August 31, 2014

Abstract

Introduction: Although several studies have investigated the characteristics of walking in patients with hip dysplasia, so far, none have described all three rotational degrees of freedom of the hip over the whole gait cycle.

This study describes the angles, torques, muscle forces and joint contact forces in 32 subjects with hip dysplasia compared to a matching control group.

Methods: Raw motion capture data from walking and standing trials was analysed in OpenSim. Joint angles were found for both standing and walking trials. Joint torques, hip muscle and joint contact forces were calculated only for the walking trials.

Results: There were only very small, insignificant differences between the two groups while standing. Kinematic differences during walking were decreased hip extension and increased internal rotation of the hip and pronation of the ankle in the dysplastic group compared to the control group. Hip abduction and external rotation torques were increased, while hip flexion and ankle supination torques were decreased in the dysplastic group compared to the control group. Hip muscle and joint contact forces were generally lower and the latter directed more vertically in the dysplastic group compared to the control group.

Conclusion: During walking, the HD group expressed decreased hip extension and increased ankle pronation compared to the control group. This might explain the increased external hip rotation torque and decreased anterior component of the JCF observed in the HD group.

Introduction

Gait deviations in patients with hip dysplasia (HD), as a result of pain due to reduced covering of the femoral head by the acetabulum, have been observed in several studies e.g., [10, 18, 17, 19, 21, 6]. The deviations occur in both the sagittal, frontal and transversal plane [19]. Despite using 3D motion capture, gait analyses are often only presented in two dimensions, e.g., [10, 18, 6] thereby excluding two of three rotational degrees of freedom of the hip joint.

By investigating people with reduced lumbar lordosis, it has been found that posterior pelvic tilt decreases acetabular cover of the femoral head and concentrates the pelvic load to the anterior part of the acetabulum [24]. Furthermore,
the anterior cover decreases more with increased posterior pelvic tilt in dysplastic hips than in healthy hips [3]. Since most labrum damages in dysplastic hips occur anteriorly [7, 8], investigating pelvic tilt seems highly relevant.

Most studies on joint loads in HD address the role of acetabular covering of the femoral head e.g., [9, 13, 16, 23, 25]. When authors use forces to describe the load profile occurring during walking, data is taken from measurements on instrumented hip prostheses which do not take alterations from HD specific gait deviations into account [4, 8].

Joint angles and net joint torques are relevant parameters for describing gait patterns. Assumptions on the effect on muscle and joint loads should be done with care, because net torque size depends on both protagonist and antagonist muscle force. It is therefore not possible to draw definite conclusions of the muscle force sizes from the net joint torques. In HD, decreased acetabular covering of the femoral head increases the hip contact pressure [16, 15]. Calculating the joint contact force (JCF) when performing gait analyses seems very relevant, since this is the other factor affecting joint contact pressure. In this study, the gait analysis is taken one step further, compared to previous HD gait studies, by including hip muscle forces and JCFs. Results will be presented in all three dimensions to see if changes occur in dimensions not reported in previous studies.

Methods

The raw motion capture data also used by Jacobsen et al. [10] was used to extend the calculations to include muscle forces and JCFs. A detailed description of subjects and laboratory procedures can be found in the publication by Jacobsen et al. [10]. In short, the study included of 32 subjects with symptomatic HD (unilateral or bilateral) scheduled for operation and a matching control group. A total of 38 reflective markers were placed on the lower extremities and pelvis for the standing trial. Markers on anatomical landmarks were removed before doing the walking trials, leaving markers on feet, pelvis and in clusters on shanks and thighs. For the standing trial, subjects were standing upright and barefooted with both feet on the force platform. Subjects were also barefooted during the walking trials.

Walking trials were analyzed using OpenSim 3.2 [5]. The musculo-skeletal model used was the generic OpenSim model Gait 2392 which has 23 degrees of freedom and 92 force actuators (muscles) [2]. Gait 2392 has lower extremities, pelvis and torso. Virtual metatarsal markers were associated with the calcaneus, thereby eliminating movement of the metatarsophalangeal joint. The model was scaled to match the size and strength of each subject based on marker measurements and bodyweight. Since position of the torso had not been recorded, all mass and inertia properties for the torso were reduced to 1x10^{-5} so that analyses would not be biased by a faulty torso position in OpenSim. The OpenSim inverse kinematics tool was used to calculate kinematics (joint angles) from marker positions in the raw motion capture data. Joint moments were determined using the inverse dynamics (ID) tool in OpenSim.

Individual muscle forces were calculated in OpenSim using static optimization (SO), which minimises the sum of squared activations, while being constrained by muscle force-velocity and force-length properties. Ideal actuators
were added to knee, ankle, subtalar and metatarsophalangeal joints to make the model more robust for SO. Muscle forces were then used to calculate hip JCF.

Kinematic results were filtered at 6 Hz before doing the ID and SO investigations, using the built-in lowpass filter (3rd order Butterworth) of OpenSim. Median values for both lower extremities of each subject, for the whole gait cycle, were extracted to be used for making mean curves for each group.

From the HD group, legs scheduled for operation were included. From the control group, a random leg from each subject was picked out.

Joint torques were normalized to body mass. Muscle forces and JCFs were normalised to body mass \(^{2/3}\) [11].

Two-tailed t-tests were performed on 5% significance level were done on all results to evaluate differences between the two groups.

### Results

Graphs in this section show the parameters for the whole gait cycle. The gait cycle starts with initial contact (IC) at 0% and finishes right before next IC at 100%. Swing phase starts about 65% into the gait cycle. The grey lines in the figures illustrate +/- 1 SD. The power of all statistical tests was > 0.9.

#### Standing Trials

The mean results from the standing trial for each group are listed in table 1. The angles are defined relative to the default position of the musculo-skeletal model Gait 2392 [2].

<table>
<thead>
<tr>
<th></th>
<th>HD OP</th>
<th>SD</th>
<th>HD non-OP</th>
<th>SD</th>
<th>Control</th>
<th>SD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posterior Pelvis Tilt</td>
<td>2</td>
<td>4</td>
<td>NaN</td>
<td>NaN</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>Medial Pelvis List</td>
<td>1</td>
<td>3</td>
<td>NaN</td>
<td>NaN</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>Pelvis Rotation</td>
<td>1</td>
<td>3</td>
<td>NaN</td>
<td>NaN</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>Hip Flexion</td>
<td>-6</td>
<td>5</td>
<td>-7</td>
<td>5</td>
<td>-7</td>
<td>5</td>
</tr>
<tr>
<td>Hip Adduction</td>
<td>-1</td>
<td>2</td>
<td>-2</td>
<td>2</td>
<td>-2</td>
<td>2</td>
</tr>
<tr>
<td>Internal Hip Rotation</td>
<td>-2</td>
<td>5</td>
<td>-2</td>
<td>6</td>
<td>-2</td>
<td>4</td>
</tr>
<tr>
<td>Knee Extension</td>
<td>2</td>
<td>4</td>
<td>3</td>
<td>4</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Ankle Dorsiflexion</td>
<td>1</td>
<td>2</td>
<td>1</td>
<td>2</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Ankle Supination</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>2</td>
</tr>
</tbody>
</table>

Table 1: Standing poses of the two groups. For the HD group positive pelvis list is towards side not undergoing surgery, while pelvis rotation is towards OP side. Values are in degrees.

#### Joint Angles

HD subjects had decreased peak hip extension (\(p = 0.04\)). The difference is illustrated in figure 2a.

The HD group also had lower peak plantarflexion at TO (\(p = 0.04\)) and ankle supination during propulsion (\(p = 0.04\)). See figure 3c.

#### Net Joint Torques

The hip abduction and external rotation torques were increased at propulsion.
in the HD group compared to the control group (p = 0.02 and p = 0.01, respectively). The control group made a small internal rotation torque right before TO whereas HD subjects kept an external rotation torque.

**Muscle Forces**

Seven of the 18 muscles crossing the hip joint are displayed to represent all muscle forces. In general, peak muscle forces across the hip were lower in the HD group than in the control group and there was a tendency for curves to be flatter (figure 6). The second peaks of gluteus medius and minimus or the sartorius peak were not significantly different in the two groups. The piriformis force in the last third of stance is greater in the HD group than in the control
Joint Contact Forces
The JCF of the hip is expressed in the local coordinate system of the pelvis. Positive directions for $F_x$, $F_y$, and $F_z$ are anterior, cranial and medial, respectively.

Greatest JCF occurred around the time of propulsion. The force in the anterior direction was lower in the HD group compared to the control group ($p = 0.04$). The vertical force component was not different in the two groups, which means that the $F_y/F_x$ ratio, at the peaks around propulsion, was higher for the HD group, hence, the force was directed more vertically in the acetabulum.

Discussion
Standing Trials
Only minor, insignificant differences were observed between the two groups. Differences in standard deviations were also very small and insignificant. Therefore, neither the pain avoidance techniques reported by [13] nor an increased anterior load due to excessive posterior tilt [24], can be assumed from the result of the standing trials. Since subjects were told to stand with both feet on the force platform, the results presented in table 1 might not reflect the typical standing poses of subjects.
Figure 6: Muscle forces across the hip used during walking

(a) Gluteus Maximus  (b) Gluteus Medius  (c) Gluteus Minimus  
(d) Iliopsoas  (e) Rectus Femoris  (f) Sartorius

(g) Piriformis  (h) Adductor Magnus

Figure 7: Joint contact forces in the hip during walking

(a) HD group  (b) Control group

Walking Trials
The results suggest that the HD group decreased the extension of the hip, while applying an external rotation torque in order to reduce the load on the anterior
part of the acetabulum. Anterior acetabular force has been shown to increase with hip extension [14]. Therefore, decreasing peak hip extension is likely to be a pain avoidance technique, as suggested by e.g., [14, 10]. The increased external rotation torque produced by the external hip rotators could also reduce the anterior force component, as they pull the femoral head posteriorly. This is seen in the increased piriformis force during propulsion in the HD group. Furthermore, when investigating the force developed in different parts of the gluteus medius and minimus right before TO, there was an increased force in the posterior part of gluteus minimus (p = 0.01) and a tendency of an increased force in the posterior part of gluteus medius (p = 0.06) in the HD group compared to the control group.

A coupling between internal hip rotation and ankle pronation has been reported in previous studies, [22, 20] and medial foot support is commonly implemented in orthotic management of excessive internal hip rotation [12]. Even though no significant difference in internal hip rotation was found between the two groups, it is possible that the coupling is still present, but reduced due to the decreased hip extension and walking speed in the HD group compared to the control group (lower walking speed was also reported by [10]). Tiberio [22] describes how excessive ankle pronation can cause internal hip rotation, which in turn causes overloading of the external hip rotators when decelerating the internal rotation of the femur. In other words, a greater external hip rotation torque is generated due to excessive ankle pronation [22]. The same pattern is seen in the HD group compared to the control group. Therefore, increased ankle pronation might be a strategy to control the GRF to only generate an internally rotating torque, so they can rely on external rotators to stabilise the hip. It also means that there is no need for an internal rotation torque at terminal stance, as observed in the control group (figure 4b).

The increased hip abduction torque, in the HD group compared to the control group, seems to be realised by a reduction in hip adductor force. The difference occurs at terminal stance, about 60% into the gait cycle. It is also the time of stance where the medial JCF component is smallest. No significant reduction was observed in the medial JCF component at this time, but because the dysplastic acetabulum does not provide proper lateral covering of the femoral head, it is most likely the time where the hip is most unstable. Therefore, a greater hip abduction moment might stabilise the dysplastic hip.

Jacobsen et al. [10] found a significantly decreased flexion torque in the HD group compared to the controls. The difference was not found in this study despite using the same data. This is likely due to different calculation methods, as recently discussed on Biomch-L [1]. In short, Jacobsen et al. used a 6 degrees of freedom approach, whereas we used the global optimisation (inverse kinematics) method provided in OpenSim, in which the hip joint is constrained to three degrees of freedom. However, if a decreased hip flexion torque had been observed in the HD group compared to the control group, it would have been due to decreased flexor or increased hip extensor muscle forces. Either way the difference between the two groups in anterior acetabular load, would likely have been even greater.

A small error in the absolute results might have occurred because we used a standard musculoskeletal OpenSim model based on a male subject while most subjects in this study are female. However, since the results are based on differences between the two groups, such an error would be systematic and
appear in both groups, and not affect the relative difference between them. The addition of residual actuators in the SO calculations were necessary for the analysis to run with data filtered at 6 Hz. These were used to account for noise in the kinematic trials that was not filtered out and forces in the model not exerted by muscles. When big residual actuator forces were applied, the nature of the force was investigated by plotting it. The residual force was either much smaller than the torque developed in that joint or sudden or brief but big peaks. In the latter case, other trials for the same limb were investigated to ensure that at least one other trial did not show the same peak. This way, the peak was removed when extracting median data for that specific limb. Thus, the inclusion of residual actuators did not bias the result.

Conclusion

During walking, the HD group expressed decreased hip extension and increased ankle pronation compared to the control group. This might explain the increased external hip rotation torque and decreased anterior component of the JCF observed in the HD group.

References


1 Introduction

This tutorial shows how to use OpenSim 3.2 for processing MOCAP data. The steps covered are

1. Data
   (a) Brief notes on data collection and musculo-skeletal model selection
   (b) Preparation of data
2. Scaling the model
3. Inverse kinematics
4. Static optimization and determination of joint reaction forces
5. Inverse dynamics

The data used in this tutorial comes from a study on hip dysplasia where gait patterns from patients with untreated symptomatic hip dysplasia were compared to a matching control group. Since data was collected for another study where it was not analysed using OpenSim some recommendations mentioned in this tutorial are not implemented in the examples.

Focus will be put on how to use OpenSim and less on how the software works, since the latter can be found in the OpenSim documentation [2]. Many of the settings that will be set up in this tutorial can be reused for analysing other, similar data sets.

2 Data

When collecting data to be analysed in OpenSim, the following should be considered:

To properly track both translation and rotation of a segment, at least three markers are needed. OpenSim uses information on all segment masses and inertias for inverse dynamics calculations. To increase reliability of calculations, it is therefore recommended to track movements of all segments – even those proximal of the joint of interest. Photo documentation of marker placement on all test subjects will make virtual marker placement in OpenSim much easier.

To import C3D files into OpenSim, they need to be preprocessed. This can be done in Matlab with the tools provided in the Matlab OpenSim Pipeline Tools [3] available via the OpenSim website. These tools can convert C3D files into the marker file (TRC file format) and the ground reaction force file (MOT file format). To use the Matlab tools they need to be added to the Matlab search path.

OpenSim uses virtual musculo-skeletal models for doing movement analyses. It is vital to choose a model that matches the study that is done. For analysing gait patterns the generic OpenSim model Gait 2392 does the job. This model has 23 degrees of freedom and 92 muscles [1]. This and other musculo-skeletal models can be downloaded for free via the OpenSim website [1].
3 Scaling

Basically, scaling works by comparing the Euclidean (linear) distance between two virtual markers with the distance between the two matching markers in the marker file. Therefore, scaling will only work if the names of the virtual markers exactly match the ones from the experimental data set so that the software can associate virtual and experimental markers.

The workflow of the scaling procedure is

1. Assuming OpenSim is running, open a model. Press File > Open Model... and navigate to desired model (OSIM file). In this example, the model is located in \OpenSim 3.2\Models\Gait2392_simbody.osim. The model should now appear in both the navigator pane and the graphics window.

2. Add markers to the model. First, the marker on the right anterior superior iliac spine will be added

(a) Expand the loaded model in the Navigator pane

(b) Right click markers and choose Add new
(c) A marker is now visible in both the graphical window and in the Navigator pane.

(d) Click on the name of the newly created marker, named **NewMarker**.
(e) Check the **Properties** window below the navigator pane. It should look something like the picture below.

![Properties Window](image)

(f) Press **ctrl** on the keyboard and click on the marker in the graphics window. The marker is now yellow. Let go of the **ctrl** button.
(g) Drag the marker close to the where it should be located

(h) Click on **NewMarker** in the navigator pane and fill in the fields as shown below
The marker is now associated with the pelvis and therefore its location is described in the local coordinate system of the pelvis. Repeat step 2a-2h for the rest of the markers. Remember to name them exactly like the markers in the experimental data set. The order of the markers in the list can not be changed. It is therefore recommended to keep a system to make it easier to find specific markers in the future.

(i) Save the model. The markers are now a part of the model.

(j) To save the marker configuration for use in another model, right click Markers in the navigator pane and then Save to File... It is recommended to save the marker configuration if more test subjects are being scaled. This way if the scaling needs to be redone, marker placement steps can be skipped.

3. Preview static pose by clicking File > Preview Experimental Data... Choose marker file from the static trial. The markers will appear in the navigator pane.

4. Double click the model name in the navigator pane to make it current.

5. Position the model to match the experimental markers of the pelvis. This is done in the Coordinates pane by adjusting the translational coordinates of the pelvis. In the figure below, the pink markers are virtual markers and the blue markers from the experimental data set.
6. Adjust the virtual markers to make the irregular four-sided polygon created by the virtual markers resemble the experimental markers. This process can be made easier with photo documentation from the data collection to evaluate the distance between bone and marker of that particular subject. To select a marker, choose it from the navigator pane or click on the marker in the model window while holding down \texttt{ctrl} on the keyboard. Move it near the desired place with the cursor or change its location in the properties window. To make sure to get a symmetrical marker placement, fine tune it using the properties window.
When markers are positioned it is time for the actual scaling process.

7. Open the scale tool by clicking **Tools > Scale Model...** Note that it is the model marked as current that will be scaled.

8. Fill in the fields in scale tool. Use the marker file from the static trial as **Marker data for measurement** and **Marker data for static pose**.
9. Click the **Scale factors** pane

10. To scale the model it is necessary to assign the before mentioned distances between marker pairs to each model body. This is done by clicking **Edit Measurement Set**
11. Name the measurements and pick the markers to be used for each of them. Only markers on anatomical landmarks should be used for scaling.

12. Assign measurements to each of the bodies. Some bodies, such as the pelvis, are best scaled non-uniformly. In this example, uniform scaling has been used only for femurs.
13. Evaluate the applied scale factors to ensure that the scaling will resemble the test subject. If something seems odd, such as scale factors for one leg being much greater than for the other, the virtual markers need to be further adjusted. The scale tool does not update automatically, so save the scale settings, close the scale tool, adjust markers, open the scale tool again and load the previously saved scale settings.

14. Click the Static Pose Weights pane. Use the markers on anatomical landmarks to set the static pose. Joint angles that are known with reasonable degree of confidence can also be used to set the static pose. In this example, the test subject is standing in a neutral position, therefore the knee, ankle and subtalar angles should be close to zero. By adding a weight to a coordinate or marker it is possible to state how much the static pose should depend on that element.
15. Save the scale settings again.

16. Go back to the Settings pane to ensure that Preview static pose (no marker movement) is checked.

17. Click Run. A new, scaled model will be created and added to the navigator pane. Do not close the scale tool yet.

18. Evaluate the results of the scaling visually and by investigating the joint angles in the Coordinates pane. If scaling and static pose are not reflecting the test subject’s dimensions and posture, move markers and adjust joint angles and run the scale tool again.
19. When the scaling, static pose and placement of markers are acceptable, uncheck **Preview static pose (no marker movement)** and run the scale tool again.

20. The virtual markers are now moved to match the experimental data from the static trial
21. Save the scaled model

The model is now scaled, but the maximum muscle forces in the model are not. This can be done by editing each of the muscles manually in the OpenSim GUI, but it would be rather time consuming. Instead it can be done with the `strengthenModel.py` script, which can be found in folder `C:\OpenSim 3.2\Scripts\GUI_Scripting`

22. To edit the script, click **Scripts > Open...** and navigate to the script. The script is opened in the graphics window and should look like the picture below
23. Edit the scale factor as shown below
24. Save the current script. Either click **Scripts > Save current script** or press **ctrl+s**

25. Run the script: Click **Scripts > Run...** and pick the **strengthenModel.py** script

26. A pop up window will tell that the model has been scaled and where it has been saved to. If the script is not changed, the model will be saved to the same folder as the original model, with **_stronger** added as suffix

27. Close the pop up window

28. Open the newly scaled model in OpenSim and continue the work using this.

Since data used for this tutorial does not include markers on the torso, and therefore its position is unknown, it is necessary to remove the torso mass and inertia properties. This way the result will not be biased by a faulty torso position

29. In the navigator pane, locate the torso and edit the mass properties. Note that the mass and inertias are not set to zero, since this would make it impossible for the solver to find a result. Instead they are just heavily reduced
4 Inverse Kinematics

1. To load the inverse kinematics tool, click Tools > Inverse Kinematics...

2. Load the marker file (TRC file) by adding its path in the red bar. To browse for the file, click the folder button to the right of the bar. Note that the time range is set automatically. This is only done because the initial time range was set to -1. If a new file is loaded, it will have the time range as in the picture below even though it is different in the motion file.

3. Click the Weights pane. All markers in the model are listed and have the weight value 1. In this data set, markers on most anatomical land-
marks have been removed. Therefore, the inverse kinematics tool cannot determine their value (location) and the value fields are marked in red and labelled From File – NOT FOUND!

4. Uncheck the markers that are not included in the experimental data. Note that the Run button is now activated
5. Assign higher weights to markers with most confidence (cluster and pelvis markers). This is done by marking the desired marker and changing the value in the weight field in the upper right corner.

![Inverse Kinematics Tool](image.png)
6. Save the inverse kinematics settings file

7. Click **Run** to execute the inverse kinematics tool. A motion called **Results** is created under Motions in the navigator tree.

8. Evaluate the result by inspecting marker errors in the **Messages** window in the bottom of the screen. According to the OpenSim documentation RMS should be below 0.002 and max less than 0.004.

9. Evaluate the result by associating motion data to the created motion. Right click **Results** and choose **Associate Motion Data**...
10. Locate the marker file used for the inverse kinematics. The file will appear under **Results** and blue markers (experimental markers) will appear together with the virtual markers in the graphics window. Do this again to associate the ground reaction force file.

11. Set the playback speed and click **Play forward**
12. Watch the model move

13. Observe if any of the experimental markers move unexpectedly causing extreme model movements
(a) if the movement is acceptable, right click Results and choose Save as...

(b) If one or more markers are causing problems, uncheck them in the Weights pane of the inverse kinematics tool and click Run again. In the picture below, the inferior posterior marker of the left thigh cluster and the superior posterior marker of the left shank cluster seem to be the problem.

14. Save the motion when the result resembles the motion of the test subject.

4.1 Tips

- Use the inverse kinematics result to evaluate the previously made scaling and static pose positioning:
  - In the right side of the graphics window, click on +Z view to watch the model from the left side.
– Zoom in on the model and place it so that the foot is close to the bottom of the window (do not rotate the model!). The bottom of the window will be used as a ruler.

– Click play forward and watch the model move.

– During midstance the forefoot and heel should be aligned with the bottom of the window.

• Sometimes limiting the motion by adding a value and weight to a coordinate (as in the scale tool) helps make the static optimization run. Be careful not to give it too great a weight since it might bias the recorded movement.

• By entering a file name in the Output section of the Settings pane (see figure 2), motion file will automatically be saved when running the tool.
5 Static Optimization and Joint Contact force Analysis

Static optimization can be done either from the static optimization tool or the analyze tool. The setup is the same, but since joint reaction analysis can only be done from the analyze tool, it is easier to set up this simultaneously.

1. Click **Tools > Analyze**

![Image of Analyze Tool interface]

2. Fill in the required fields
   
   (a) Choose **Motion > From** file and browse for the previously made kinematics file
   
   (b) Check **Filter coordinates** and choose a low-pass filtering frequency
   
   (c) Time range is automatically taken from the kinematics file, but can be edited manually
(d) Fill in **Prefix** for the analysis so output files can be recognized later
(e) Choose the output **Directory** where the files will be saved to

3. Click on the **Actuator and External Loads** pane
4. The tool needs an additional force set containing residual forces and moments in the first free joint in the model (the pelvis-ground joint). This file needs to be set up.

(a) Navigate to the pelvis in the OpenSim main window navigator win-
(b) Find and copy the **mass center** from the properties window below the navigator window. This is the point in which the additional translational forces of the pelvis-ground joint are placed.

(c) In the OpenSim main window click **Edit > File (.xml)**...
(d) Navigate to the folder where the model was downloaded to and find the additional actuator file. In this example it can be found in C:\OpenSim 3.2\Models\Gait2392_Simbody\gait2392_CMC_Actuators.xml. This file has an ideal actuator for each degree of freedom in the model.

(e) For the static optimization analysis only the actuators for $F_X$, $F_Y$, $F_Z$, $M_X$, $M_Y$ and $M_Z$ should be enabled. Therefore, disable all the
(f) Change the location of point in $\mathbf{F}_X$, $\mathbf{F}_Y$ and $\mathbf{F}_Z$ to that of the pelvis center of mass
(g) Save the edited actuator file

5. Click **Edit** in the **Actuators and External Loads** pane
6. Click **Add** and browse for the actuator file by clicking the folder button to the right of the red textbox.

7. The actuator file (including path) will shown in the list. Click **OK**.
8. The analyze tool should look like the picture below

9. Check the **External Loads** checkbox
10. Load or create an external loads file

- To load a previously created file, click the folder button and navigate to the file.
- If the file has not been previously created, create it now.
  
  (a) Click the edit button (the button furthest to the right).
  
  (b) Click the folder button to browse for the force data file.

[Image of the External Loads window]

[Image of the External Forces window]
(c) Click **Add**

(d) Enter a name for the force and choose which body it should be applied to

(e) Fill in the rest of the fields and click **OK**

(f) The external forces should now look something like the picture below
(g) Save the external loads file.

11. The analyze tool should now look something like the picture below
12. Click the **Analyses** pane
13. Click Add > StaticOptimization
14. The static optimization is now set up
15. To set up the joint contact analysis, click **Add > JointReaction**
16. Click on **JointReaction** and then click **Edit**
As default reactions forces in all joints (expressed in ground coordinate system) are calculated. This will be changed so forces in each hip, knee and ankle expressed in pelvis, femur and tibia coordinate system respectively.

17. Fill in the **Property Editor**

(a) In `force_file` enter the path to the force file that will be generated by the static optimization. It will be placed in the directory from step 2e and has the suffix `_StaticOptimization_force.sto`

(b) Add joint names so that they match the ones below. These are the same names that can be found in the model file (e.g. `gait2392_simbody.osim`)

(c) Set `apply_on_bodies` to `parent`

(d) Set `express_in_frame` to `parent`
18. Click **OK**

19. Save the settings file

20. Make sure that only **StaticOptimization** is checked
21. Click **Run**. Do not change any settings in the analyze tool while OpenSim is computing

22. Observe the messages window while the static optimization is running to locate potential errors. With the settings from this Performance should be below 20 – if it goes much above that, the program is struggling to find a solution to the static optimization problem and will most likely crash.

23. Uncheck **StaticOptimization** and check **JointReaction**

24. Click **Run** to calculate joint contact forces
25. The directory set in step 2e should now contain the following files

5.1 Tips

Before executing the enabled analyses, OpenSim loads the necessary files for all analyses. Since the JointReaction investigation uses the _StaticOptimization_force.sto file created by the static optimization, it is essential to run the static optimization before the joint reaction analysis.

If the static optimization fails and the program crashes, the following can be used for troubleshooting:

- Check that the static optimization setup has been done correctly
  - If the tool fails right after execution, the kinematics file has most likely not been filtered
  - If the tool fails around the time when the external forces are applied, it could be that the GRF file is from another trial or not applied to the right body

- If anything has been changed in the setup while the analysis is running, these changes might be implemented in the running analysis. If for instance the prefix is changed, the new prefix will be used by the tool when printing the results.

- Troubleshoot the joint(s) causing the problem by replacing the actuator file with one that has reserve actuators for all joints (redo step 4a - 4g, but skip step 4e)
  - Run the static optimization tool again while checking the Messages window for errors
  - Plot the result of the static optimization again while checking the Messages window for errors
  - Choose the results to be plotted: Click Y-Quantity... > Load File... > StaticOptimizationJW0WL (or whatever the folder has the results of the static optimization) JW0WL0002L_StaticOptimization_force.sto > select quantity names ending with _reserve > OK
  - Choose to plot against time: X-Quantity... > time > OK
  - Add results to Curves List.: Click Add
  - See if any of the reserve actuators have been used. Actuators that have applied significant force to a joint movement usually show where the problem occurs
– **Solutions**

* If the messages window states that problems with fiber lengths or pennation angles, see there is probably an issue with extreme joint angles. Check that the static pose is reflecting the actual pose of the test subject during the static trial.
* If the messages window states that muscle forces are close to their maximum, the model is probably too weak for the movement.
* Have the muscle forces been scaled?
* Check that the inverse kinematics have been done properly (see kinematics tips).
* If there are any extreme accelerations (causing extreme, sudden peaks in a reserve actuator), consider if the kinematics data has been properly filtered.
* Sometimes data sets are not reflecting the movement of the skeleton properly. Try some of the other trials to see if they work.
6 Inverse Dynamics

Inverse dynamics uses the inverse kinematics result and the GRF file to calculate joint moments. It does not depend on static optimization and can be run before that.

1. Click Tools > Inverse Dynamics...

2. Fill in the fields in the window
   (a) As input browse to inverse kinematics result file
   (b) Check Filter coordinates and enter lowpass filter frequency
   (c) Time range to process is automatically set to that of the inverse kinematics file
   (d) In Output choose the Directory to where the inverse dynamics results should be saved
3. Click the **External Loads** pane

4. Check **External Loads** and add the external loads file
   - Browse for file if it has already been created in another tool
   - If the file has not been previously created, create it now
     - To load a previously created file, click the folder button and navigate to the file
     - If the file has not been previously created, create it now
(a) Click the edit button (the button furthest to the right)

(b) Click the folder button to browse for the force data file

(c) Click Add
(d) Enter a name for the force and choose which body it should be applied to.

(e) Fill in the rest of the fields and click **OK**.

(f) The external forces should now look something like the picture below.
5. The inverse dynamics tool should look like this

6. Click **Run** to execute the inverse dynamics calculations

7. Open the folder the inverse dynamics results were saved to. The folder has a file named `inverse_dynamics.sto`
8. Rename the file. If not renamed, it will be overwritten at when running another inverse dynamics calculation

6.1 Tips

- Remember to rename the output file from the inverse dynamics calculation. Otherwise it will be overwritten in the next execution of the tool.

- After running a number of inverse dynamics calculations it sometimes happens that the computing process slows down significantly. It usually occurs when the body that the external forces are applied is changed from one trial to another (i.e. stance leg changes side). To fix this, save the inverse dynamics settings, close the tool, open it again, load the settings and run the next analysis.

- Inverse dynamics analyses can also be run within the analyse tool. In that case, add **Actuation** as one of the analyses to run. This will not only produce moment of force of each joint, but also velocity and power.
References

